2014年4月29日火曜日

OpenGL: GL-1.4からGL-4.2までのAPIを使い分けたmipmapなテクスチャー周り

  • 参考
    1. http://www.opengl.org/wiki/Common_Mistakes#Automatic_mipmap_generation
GLES2(=WebGL1)とかいうGL3未満の環境からいけてるなういPC(GL-4.4)まで対応したmipmapなOpenGLのテクスチャー周りを #if したらそこそこカオスになりました。そこそこだけど。

0 件のコメント:

コメントを投稿